InfraGuard

BIND 9 9.19 漏洞

影响 BIND 9 9.19 系列的已知 CVE 共 11 个。

8.2 最高 CVSS

修复版本

9.19.59.19.99.19.179.19.21
检查您的版本named -v

影响 9.19 的 CVE

CVE 标题 CVSS 被利用 EPSS 发布日期
CVE-2022-2881 Buffer overread in statistics channel code 8.2 — 2022-09-21
CVE-2022-3924 named configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota 7.5 — 2023-01-26
CVE-2022-3736 named configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries 7.5 — 2023-01-26
CVE-2023-50387 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote atta... 7.5 — 2024-02-14
CVE-2022-1183 Destroying a TLS session early causes assertion failure 7.5 — 2022-05-19
CVE-2023-50868 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows r... 7.5 — 2024-02-14
CVE-2022-3080 BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate une... 7.5 — 2022-09-21
CVE-2023-3341 A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 — 2023-09-20
CVE-2022-3094 An UPDATE message flood may cause named to exhaust all available memory 7.5 — 2023-01-26
CVE-2022-2906 Memory leaks in code handling Diffie-Hellman key exchange via TKEY RRs (OpenSSL 3.0.0+ only) 7.5 — 2022-09-21
CVE-2022-2795 Processing large delegations may severely degrade resolver performance 5.3 — 2022-09-21

在您自己的服务器上追踪这些版本

InfraGuard 从每台服务器收集已安装软件的版本,并标出存在已知漏洞的版本。自托管部署——数据不会离开您的网络。

每周已被利用漏洞摘要

每周一次,推送与自托管服务器相关的 KEV 新增条目。不发送其他邮件。

数据来源:CVE List(CVE® Program)、NVD、CISA KEV、FIRST EPSS(EPSS 详见 https://www.first.org/epss)、endoflife.date。软件列表:awesome-selfhosted(CC BY-SA 3.0)。