InfraGuard

BIND 9 9.18 – Schwachstellen

36 bekannte CVEs betreffen die Versionslinie 9.18 von BIND 9.

8.6 max. CVSSSupport beendet am 2026-06-30

Behoben in

9.18.79.18.119.18.189.18.199.18.249.18.479.18.49
Version prüfennamed -v

CVEs, die 9.18 betreffen

CVE Titel CVSS Ausgenutzt EPSS Veröffentlicht
CVE-2026-13321 DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 — 2026-07-22
CVE-2022-2881 Buffer overread in statistics channel code 8.2 — 2022-09-21
CVE-2023-4236 named may terminate unexpectedly under high DNS-over-TLS query load 7.5 — 2023-09-20
CVE-2026-11622 Potential memory usage beyond configured limits 7.5 — 2026-07-22
CVE-2023-5679 Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 — 2024-02-13
CVE-2023-2829 Malformed NSEC records can cause named to terminate unexpectedly when synth-from-dnssec is enabled 7.5 — 2023-06-21
CVE-2022-3924 named configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota 7.5 — 2023-01-26
CVE-2026-12617 Record ordering based unexpected exit with CNAME or DNAME 7.5 — 2026-07-22
CVE-2022-3736 named configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries 7.5 — 2023-01-26
CVE-2026-3039 BIND 9 server memory exhaustion during GSS-API TKEY negotiation 7.5 — 2026-05-20
CVE-2023-50387 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote atta... 7.5 — 2024-02-14
CVE-2022-1183 Destroying a TLS session early causes assertion failure 7.5 — 2022-05-19
CVE-2022-0667 Assertion failure on delayed DS lookup 7.5 — 2022-03-22
CVE-2022-0635 Versions affected: BIND 9.18.0 When a vulnerable version of named receives a series of specific queries, the n... 7.5 — 2022-03-23
CVE-2023-50868 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows r... 7.5 — 2024-02-14
CVE-2023-5517 Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 — 2024-02-13
CVE-2026-1519 Excessive NSEC3 iterations cause high CPU load during insecure delegation validation 7.5 — 2026-03-25
CVE-2023-2911 Exceeding the recursive-clients quota may cause named to terminate unexpectedly when stale-answer-client-timeo... 7.5 — 2023-06-21
CVE-2022-3080 BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate une... 7.5 — 2022-09-21
CVE-2023-4408 Parsing large DNS messages may cause excessive CPU load 7.5 — 2024-02-13
CVE-2026-13204 Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 — 2026-07-22
CVE-2026-5946 Invalid handling of CLASS != IN 7.5 — 2026-05-20
CVE-2023-3341 A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 — 2023-09-20
CVE-2022-3094 An UPDATE message flood may cause named to exhaust all available memory 7.5 — 2023-01-26
CVE-2026-11721 Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 — 2026-07-22
CVE-2022-2906 Memory leaks in code handling Diffie-Hellman key exchange via TKEY RRs (OpenSSL 3.0.0+ only) 7.5 — 2022-09-21
CVE-2023-2828 named's configured cache size limit can be significantly exceeded 7.5 — 2023-06-21
CVE-2026-11331 Potential wildcard CNAME RPZ policy bypass 7.5 — 2026-07-22
CVE-2021-25220 DNS forwarders - cache poisoning vulnerability 6.8 — 2022-03-23
CVE-2026-10723 Incorrect acceptance of NSEC3 records 6.8 — 2026-07-22
CVE-2026-10822 Key Record using PRIVATEDNS algorithm may lead to unexpected exit 6.5 — 2026-07-22
CVE-2026-3592 Amplification vulnerabilities via self-pointed glue records 5.3 — 2026-05-20
CVE-2022-0396 DoS from specifically crafted TCP packets 5.3 — 2022-03-23
CVE-2022-2795 Processing large delegations may severely degrade resolver performance 5.3 — 2022-09-21
CVE-2023-5680 Cleaning an ECS-enabled cache may cause excessive CPU load 5.3 — 2024-02-13
CVE-2026-5950 Unbounded resend loop in BIND 9 resolver 5.3 — 2026-05-20

Verfolgen Sie diese Versionen auf Ihren eigenen Servern

InfraGuard erfasst die installierten Softwareversionen auf jedem Server und markiert diejenigen mit bekannten Schwachstellen. Self-Hosted – nichts verlässt Ihr Netzwerk.

Wöchentlicher Digest ausgenutzter Schwachstellen

Die für Self-Hosted-Server relevanten KEV-Neuzugänge, einmal pro Woche. Keine weiteren E-Mails.

Daten: CVE List (CVE® Program), NVD, CISA KEV, FIRST EPSS (siehe EPSS unter https://www.first.org/epss), endoflife.date. Softwareliste: awesome-selfhosted (CC BY-SA 3.0).