InfraGuard

BIND 9 9.16 – Schwachstellen

41 bekannte CVEs betreffen die Versionslinie 9.16 von BIND 9.

9.8 max. CVSSSupport beendet am 2024-03-31

Behoben in

9.16.69.16.159.16.229.16.279.16.339.16.379.16.449.16.48
Version prüfennamed -v

CVEs, die 9.16 betreffen

CVE Titel CVSS Ausgenutzt EPSS Veröffentlicht
CVE-2021-25216 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attac... 9.8 — 2021-04-29
CVE-2026-13321 DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 — 2026-07-22
CVE-2020-8616 BIND does not sufficiently limit the number of fetches performed when processing referrals 8.6 — 2020-05-19
CVE-2020-8625 A vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack 8.1 — 2021-02-17
CVE-2020-8623 A flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.c 7.5 — 2020-08-21
CVE-2026-11622 Potential memory usage beyond configured limits 7.5 — 2026-07-22
CVE-2021-25218 A too-strict assertion check could be triggered when responses in BIND 9.16.19 and 9.17.16 require UDP fragmen... 7.5 — 2021-08-18
CVE-2023-5679 Enabling both DNS64 and serve-stale may cause an assertion failure during recursive resolution 7.5 — 2024-02-13
CVE-2023-2829 Malformed NSEC records can cause named to terminate unexpectedly when synth-from-dnssec is enabled 7.5 — 2023-06-21
CVE-2022-3924 named configured to answer from stale cache may terminate unexpectedly at recursive-clients soft quota 7.5 — 2023-01-26
CVE-2022-3736 named configured to answer from stale cache may terminate unexpectedly while processing RRSIG queries 7.5 — 2023-01-26
CVE-2023-50387 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote atta... 7.5 — 2024-02-14
CVE-2020-8621 Attempting QNAME minimization after forwarding can lead to an assertion failure in resolver.c 7.5 — 2020-08-21
CVE-2022-3488 named may terminate unexpectedly when processing ECS options in repeated responses to iterative queries 7.5 — 2023-01-26
CVE-2023-50868 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows r... 7.5 — 2024-02-14
CVE-2022-38177 Memory leak in ECDSA DNSSEC verification code 7.5 — 2022-09-21
CVE-2023-6516 Specific recursive query patterns may lead to an out-of-memory condition 7.5 — 2024-02-13
CVE-2020-8620 In BIND 9.15.6 -> 9.16.5, 9.17.0 -> 9.17.3, An attacker who can establish a TCP connection with the server and... 7.5 — 2020-08-21
CVE-2022-38178 Memory leaks in EdDSA DNSSEC verification code 7.5 — 2022-09-21
CVE-2023-5517 Querying RFC 1918 reverse zones may cause an assertion failure when "nxdomain-redirect" is enabled 7.5 — 2024-02-13
CVE-2022-3080 BIND 9 resolvers configured to answer from stale cache with zero stale-answer-client-timeout may terminate une... 7.5 — 2022-09-21
CVE-2023-4408 Parsing large DNS messages may cause excessive CPU load 7.5 — 2024-02-13
CVE-2026-13204 Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 — 2026-07-22
CVE-2023-3341 A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 — 2023-09-20
CVE-2022-3094 An UPDATE message flood may cause named to exhaust all available memory 7.5 — 2023-01-26
CVE-2026-11721 Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 — 2026-07-22
CVE-2021-25215 An assertion check can fail while answering queries for DNAME records that require the DNAME to be processed t... 7.5 — 2021-04-29
CVE-2023-2828 named's configured cache size limit can be significantly exceeded 7.5 — 2023-06-21
CVE-2026-11331 Potential wildcard CNAME RPZ policy bypass 7.5 — 2026-07-22
CVE-2021-25220 DNS forwarders - cache poisoning vulnerability 6.8 — 2022-03-23
CVE-2026-10723 Incorrect acceptance of NSEC3 records 6.8 — 2026-07-22
CVE-2020-8622 A truncated TSIG response can lead to an assertion failure 6.5 — 2020-08-21
CVE-2021-25214 A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 — 2021-04-29
CVE-2020-8617 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c 5.9 — 2020-05-19
CVE-2021-25219 Lame cache can be abused to severely degrade resolver performance 5.3 — 2021-10-27
CVE-2022-0396 DoS from specifically crafted TCP packets 5.3 — 2022-03-23
CVE-2022-2795 Processing large delegations may severely degrade resolver performance 5.3 — 2022-09-21
CVE-2023-5680 Cleaning an ECS-enabled cache may cause excessive CPU load 5.3 — 2024-02-13
CVE-2020-8618 A buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer 4.9 — 2020-06-17
CVE-2020-8619 A buffer boundary check assertion in rdataset.c can fail incorrectly during zone transfer 4.9 — 2020-06-17
CVE-2020-8624 update-policy rules of type "subdomain" are enforced incorrectly 4.3 — 2020-08-21

Verfolgen Sie diese Versionen auf Ihren eigenen Servern

InfraGuard erfasst die installierten Softwareversionen auf jedem Server und markiert diejenigen mit bekannten Schwachstellen. Self-Hosted – nichts verlässt Ihr Netzwerk.

Wöchentlicher Digest ausgenutzter Schwachstellen

Die für Self-Hosted-Server relevanten KEV-Neuzugänge, einmal pro Woche. Keine weiteren E-Mails.

Daten: CVE List (CVE® Program), NVD, CISA KEV, FIRST EPSS (siehe EPSS unter https://www.first.org/epss), endoflife.date. Softwareliste: awesome-selfhosted (CC BY-SA 3.0).