InfraGuard

BIND 9 9.12 – Schwachstellen

36 bekannte CVEs betreffen die Versionslinie 9.12 von BIND 9.

9.8 max. CVSS

Behoben in

9.12.29.12.3
Version prüfennamed -v

CVEs, die 9.12 betreffen

CVE Titel CVSS Ausgenutzt EPSS Veröffentlicht
CVE-2021-25216 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attac... 9.8 — 2021-04-29
CVE-2026-13321 DNSSEC Validation Bypass via Out-of-Zone NSEC Next Field 8.6 — 2026-07-22
CVE-2020-8616 BIND does not sufficiently limit the number of fetches performed when processing referrals 8.6 — 2020-05-19
CVE-2020-8625 A vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack 8.1 — 2021-02-17
CVE-2020-8623 A flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.c 7.5 — 2020-08-21
CVE-2018-5743 Limiting simultaneous TCP clients was ineffective 7.5 — 2019-10-09
CVE-2026-11622 Potential memory usage beyond configured limits 7.5 — 2026-07-22
CVE-2017-3145 Improper fetch cleanup sequencing in the resolver can cause named to crash 7.5 — 2019-01-16
CVE-2018-5737 BIND 9.12's serve-stale implementation can cause an assertion failure in rbtdb.c or other undesirable behavior... 7.5 — 2019-01-16
CVE-2023-50387 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote atta... 7.5 — 2024-02-14
CVE-2023-50868 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows r... 7.5 — 2024-02-14
CVE-2022-38177 Memory leak in ECDSA DNSSEC verification code 7.5 — 2022-09-21
CVE-2018-5744 A specially crafted packet can cause named to leak memory 7.5 — 2019-10-09
CVE-2018-5740 A flaw in the "deny-answer-aliases" feature can cause an assertion failure in named 7.5 — 2019-01-16
CVE-2022-38178 Memory leaks in EdDSA DNSSEC verification code 7.5 — 2022-09-21
CVE-2018-5738 Some versions of BIND can improperly permit recursive query service to unauthorized clients 7.5 — 2019-01-16
CVE-2019-6477 TCP-pipelined queries can bypass tcp-clients limit 7.5 — 2019-11-26
CVE-2019-6467 An error in the nxdomain redirect feature can cause BIND to exit with an INSIST assertion failure in query.c 7.5 — 2019-10-09
CVE-2026-13204 Unexpected exit in certain situations with NSEC and NSEC3 both present 7.5 — 2026-07-22
CVE-2023-3341 A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 — 2023-09-20
CVE-2026-11721 Cache poisoning possible with label count discrepancy, RRSIG, and wildcards 7.5 — 2026-07-22
CVE-2021-25215 An assertion check can fail while answering queries for DNAME records that require the DNAME to be processed t... 7.5 — 2021-04-29
CVE-2023-2828 named's configured cache size limit can be significantly exceeded 7.5 — 2023-06-21
CVE-2021-25220 DNS forwarders - cache poisoning vulnerability 6.8 — 2022-03-23
CVE-2026-10723 Incorrect acceptance of NSEC3 records 6.8 — 2026-07-22
CVE-2020-8622 A truncated TSIG response can lead to an assertion failure 6.5 — 2020-08-21
CVE-2018-5741 Update policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentation 6.5 — 2019-01-16
CVE-2021-25214 A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 — 2021-04-29
CVE-2019-6471 A race condition when discarding malformed packets can cause BIND to exit with an assertion failure 5.9 — 2019-10-09
CVE-2020-8617 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c 5.9 — 2020-05-19
CVE-2021-25219 Lame cache can be abused to severely degrade resolver performance 5.3 — 2021-10-27
CVE-2022-2795 Processing large delegations may severely degrade resolver performance 5.3 — 2022-09-21
CVE-2019-6465 Zone transfer controls for writable DLZ zones were not effective 5.3 — 2019-10-09
CVE-2018-5736 An error in zone database reference counting can lead to an assertion failure if a server which is running an... 5.3 — 2019-01-16
CVE-2018-5745 An assertion failure can occur if a trust anchor rolls over to an unsupported key algorithm when using managed... 4.9 — 2019-10-09
CVE-2020-8624 update-policy rules of type "subdomain" are enforced incorrectly 4.3 — 2020-08-21

Verfolgen Sie diese Versionen auf Ihren eigenen Servern

InfraGuard erfasst die installierten Softwareversionen auf jedem Server und markiert diejenigen mit bekannten Schwachstellen. Self-Hosted – nichts verlässt Ihr Netzwerk.

Wöchentlicher Digest ausgenutzter Schwachstellen

Die für Self-Hosted-Server relevanten KEV-Neuzugänge, einmal pro Woche. Keine weiteren E-Mails.

Daten: CVE List (CVE® Program), NVD, CISA KEV, FIRST EPSS (siehe EPSS unter https://www.first.org/epss), endoflife.date. Softwareliste: awesome-selfhosted (CC BY-SA 3.0).