InfraGuard

BIND 9 9.10 – Schwachstellen

60 bekannte CVEs betreffen die Versionslinie 9.10 von BIND 9.

1 KEV9.8 max. CVSS

Behoben in

9.10.29.10.39.10.49.10.8
Version prüfennamed -v

CVEs, die 9.10 betreffen

CVE Titel CVSS Ausgenutzt EPSS Veröffentlicht
CVE-2015-5477 named in ISC BIND 9.x before 9.9.7-P2 and 9.10.x before 9.10.2-P3 allows remote attackers to cause a denial of... 7.5 KEV 99.6% 2015-07-29
CVE-2021-25216 A second vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attac... 9.8 — 2021-04-29
CVE-2016-1286 named in ISC BIND 9.x before 9.9.8-P4 and 9.10.x before 9.10.3-P4 allows remote attackers to cause a denial of... 8.6 — 2016-03-09
CVE-2020-8616 BIND does not sufficiently limit the number of fetches performed when processing referrals 8.6 — 2020-05-19
CVE-2020-8625 A vulnerability in BIND's GSSAPI security policy negotiation can be targeted by a buffer overflow attack 8.1 — 2021-02-17
CVE-2014-8500 ISC BIND 9.0.x through 9.8.x, 9.9.0 through 9.9.6, and 9.10.0 through 9.10.1 does not limit delegation chainin... 7.8 — 2014-12-11
CVE-2017-3141 Windows service and uninstall paths are not quoted when BIND is installed 7.8 — 2019-01-16
CVE-2015-4620 name.c in named in ISC BIND 9.7.x through 9.9.x before 9.9.7-P1 and 9.10.x before 9.10.2-P2, when configured a... 7.8 — 2015-07-08
CVE-2015-5722 buffer.c in named in ISC BIND 9.x before 9.9.7-P3 and 9.10.x before 9.10.2-P4 allows remote attackers to cause... 7.8 — 2015-09-05
CVE-2010-0382 ISC BIND 9.0.x through 9.3.x, 9.4 before 9.4.3-P5, 9.5 before 9.5.2-P2, 9.6 before 9.6.1-P3, and 9.7.0 beta ha... 7.6 — 2010-01-22
CVE-2019-6469 BIND Supported Preview Edition can exit with an assertion failure if ECS is in use 7.5 — 2019-10-09
CVE-2020-8623 A flaw in native PKCS#11 code can lead to a remotely triggerable assertion failure in pk11.c 7.5 — 2020-08-21
CVE-2018-5743 Limiting simultaneous TCP clients was ineffective 7.5 — 2019-10-09
CVE-2019-6468 BIND Supported Preview Edition can exit with an assertion failure if nxdomain-redirect is used 7.5 — 2019-10-09
CVE-2017-3145 Improper fetch cleanup sequencing in the resolver can cause named to crash 7.5 — 2019-01-16
CVE-2023-50387 Certain DNSSEC aspects of the DNS protocol (in RFC 4033, 4034, 4035, 6840, and related RFCs) allow remote atta... 7.5 — 2024-02-14
CVE-2016-9131 named in ISC BIND 9.x before 9.9.9-P5, 9.10.x before 9.10.4-P5, and 9.11.x before 9.11.0-P2 allows remote atta... 7.5 — 2017-01-12
CVE-2018-5734 A malformed request can trigger an assertion failure in badcache.c 7.5 — 2019-01-16
CVE-2023-50868 The Closest Encloser Proof aspect of the DNS protocol (in RFC 5155 when RFC 9276 guidance is skipped) allows r... 7.5 — 2024-02-14
CVE-2022-38177 Memory leak in ECDSA DNSSEC verification code 7.5 — 2022-09-21
CVE-2018-5744 A specially crafted packet can cause named to leak memory 7.5 — 2019-10-09
CVE-2018-5740 A flaw in the "deny-answer-aliases" feature can cause an assertion failure in named 7.5 — 2019-01-16
CVE-2022-38178 Memory leaks in EdDSA DNSSEC verification code 7.5 — 2022-09-21
CVE-2018-5738 Some versions of BIND can improperly permit recursive query service to unauthorized clients 7.5 — 2019-01-16
CVE-2016-9147 named in ISC BIND 9.9.9-P4, 9.9.9-S6, 9.10.4-P4, and 9.11.0-P1 allows remote attackers to cause a denial of se... 7.5 — 2017-01-12
CVE-2016-9444 named in ISC BIND 9.x before 9.9.9-P5, 9.10.x before 9.10.4-P5, and 9.11.x before 9.11.0-P2 allows remote atta... 7.5 — 2017-01-12
CVE-2016-8864 named in ISC BIND 9.x before 9.9.9-P4, 9.10.x before 9.10.4-P4, and 9.11.x before 9.11.0-P1 allows remote atta... 7.5 — 2016-11-02
CVE-2023-3341 A stack exhaustion flaw in control channel code may cause named to terminate unexpectedly 7.5 — 2023-09-20
CVE-2017-3137 A response packet can cause a resolver to terminate when processing an answer containing a CNAME or DNAME 7.5 — 2019-01-16
CVE-2021-25215 An assertion check can fail while answering queries for DNAME records that require the DNAME to be processed t... 7.5 — 2021-04-29
CVE-2016-2776 buffer.c in named in ISC BIND 9 before 9.9.9-P3, 9.10.x before 9.10.4-P3, and 9.11.x before 9.11.0rc3 does not... 7.5 — 2016-09-28
CVE-2015-5986 openpgpkey_61.c in named in ISC BIND 9.9.7 before 9.9.7-P3 and 9.10.x before 9.10.2-P4 allows remote attackers... 7.1 — 2015-09-05
CVE-2015-8461 Race condition in resolver.c in named in ISC BIND 9.9.8 before 9.9.8-P2 and 9.10.3 before 9.10.3-P2 allows rem... 7.1 — 2015-12-16
CVE-2015-8705 buffer.c in named in ISC BIND 9.10.x before 9.10.3-P3, when debug logging is enabled, allows remote attackers... 7.0 — 2016-01-20
CVE-2016-2088 resolver.c in named in ISC BIND 9.10.x before 9.10.3-P4, when DNS cookies are enabled, allows remote attackers... 6.8 — 2016-03-09
CVE-2016-1285 named in ISC BIND 9.x before 9.9.8-P4 and 9.10.x before 9.10.3-P4 does not properly handle DNAME records when... 6.8 — 2016-03-09
CVE-2016-6170 ISC BIND through 9.9.9-P1, 9.10.x through 9.10.4-P1, and 9.11.x through 9.11.0b1 allows primary DNS servers to... 6.5 — 2016-07-06
CVE-2020-8622 A truncated TSIG response can lead to an assertion failure 6.5 — 2020-08-21
CVE-2018-5741 Update policies krb5-subdomain and ms-subdomain do not enforce controls promised in their documentation 6.5 — 2019-01-16
CVE-2021-25214 A broken inbound incremental zone update (IXFR) can cause named to terminate unexpectedly 6.5 — 2021-04-29
CVE-2015-8704 apl_42.c in ISC BIND 9.x before 9.9.8-P3, 9.9.x, and 9.10.x before 9.10.3-P3 allows remote authenticated users... 6.5 — 2016-01-20
CVE-2017-3136 An error handling synthesized records could cause an assertion failure when using DNS64 with "break-dnssec yes... 5.9 — 2019-01-16
CVE-2020-8617 A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c 5.9 — 2020-05-19
CVE-2017-3135 Combination of DNS64 and RPZ Can Lead to Crash 5.9 — 2019-01-16
CVE-2017-3143 An error in TSIG authentication can permit unauthorized dynamic updates 5.9 — 2019-01-16
CVE-2016-2775 ISC BIND 9.x before 9.9.9-P2, 9.10.x before 9.10.4-P2, and 9.11.x before 9.11.0b2, when lwresd or the named lw... 5.9 — 2016-07-19
CVE-2017-3140 An error processing RPZ rules can cause named to loop endlessly after handling a query 5.9 — 2019-01-16
CVE-2015-1349 named in ISC BIND 9.7.0 through 9.9.6 before 9.9.6-P2 and 9.10.x before 9.10.1-P2, when DNSSEC validation and... 5.4 — 2015-02-19
CVE-2014-8680 The GeoIP functionality in ISC BIND 9.10.0 through 9.10.1 allows remote attackers to cause a denial of service... 5.4 — 2014-12-11
CVE-2021-25219 Lame cache can be abused to severely degrade resolver performance 5.3 — 2021-10-27
CVE-2022-2795 Processing large delegations may severely degrade resolver performance 5.3 — 2022-09-21
CVE-2019-6465 Zone transfer controls for writable DLZ zones were not effective 5.3 — 2019-10-09
CVE-2017-3138 named exits with a REQUIRE assertion failure if it receives a null command string on its control channel 5.3 — 2019-01-16
CVE-2014-3214 The prefetch implementation in named in ISC BIND 9.10.0, when a recursive nameserver is enabled, allows remote... 5.0 — 2014-05-09
CVE-2014-3859 libdns in ISC BIND 9.10.0 before P2 does not properly handle EDNS options, which allows remote attackers to ca... 5.0 — 2014-06-13
CVE-2015-8000 db.c in named in ISC BIND 9.x before 9.9.8-P2 and 9.10.x before 9.10.3-P2 allows remote attackers to cause a d... 5.0 — 2015-12-16
CVE-2018-5745 An assertion failure can occur if a trust anchor rolls over to an unsupported key algorithm when using managed... 4.9 — 2019-10-09
CVE-2020-8624 update-policy rules of type "subdomain" are enforced incorrectly 4.3 — 2020-08-21
CVE-2010-0290 Unspecified vulnerability in ISC BIND 9.0.x through 9.3.x, 9.4 before 9.4.3-P5, 9.5 before 9.5.2-P2, 9.6 befor... 4.0 — 2010-01-22
CVE-2017-3142 An error in TSIG authentication can permit unauthorized zone transfers 3.7 — 2019-01-16

Verfolgen Sie diese Versionen auf Ihren eigenen Servern

InfraGuard erfasst die installierten Softwareversionen auf jedem Server und markiert diejenigen mit bekannten Schwachstellen. Self-Hosted – nichts verlässt Ihr Netzwerk.

Wöchentlicher Digest ausgenutzter Schwachstellen

Die für Self-Hosted-Server relevanten KEV-Neuzugänge, einmal pro Woche. Keine weiteren E-Mails.

Daten: CVE List (CVE® Program), NVD, CISA KEV, FIRST EPSS (siehe EPSS unter https://www.first.org/epss), endoflife.date. Softwareliste: awesome-selfhosted (CC BY-SA 3.0).